Looking for something?

You will find your answers here!

    Sorry, we didn't find any relevant articles for you.

    Send us your queries using the form below and we will get back to you with a solution.

    Important information about Symantec Certificates and Merchants using Chase Paymentech

    Product

    Chase Paymentech Front Ends through Paya

    Description

    JPMC is moving away from Symantec as the primary external issuer of certificates in response to distrust of Symantec certificates. This is an industry-wide issue that we are remediating now.  Information that you need to know: Legacy Symantec certificates will be expiring in early 2019 and all terminals in the field must be ready to cut-over to the new certificate by 3/30/19.


    Required Action

    JPMC is moving away from Symantec as the primary external issuer of certificates in response to distrust of Symantec certificates. This is an industry-wide issue that we are remediating now.


    Information that you need to know:   Legacy Symantec certificates will be expiring in early 2019 and all terminals in the field must be ready to cutover to the new certificate by 3/30/19.   New certificates are now available in the Test/VAR environment; in order to test the new certificate.  You will need to validate in the Test/VAR environment against the new certificate and associated intermediate certificates. The following 2 test URLs will be available with the new certificate in the Test/VAR environment:  netconnectvar2.chasepaymentech.com or netconnectkavar2.chasepaymentech.com.  Please ensure the Root CA: VeriSign Class 3 Public Primary CA G5 is added to the trust store included in your payment solution; however Do not remove any existing certificates.   Root CA: VeriSign Class 3 Public Primary CA G5 can be accessed through the Developer Center, under Documentation (NetConnect SSL certificate) https://secure.paymentech.com/developercenter  Frequently check Developer Center for the latest updates on the certificate. 


    Additional details 

    • VeriFone – Not impacted
    • Ingenico
    • The application CPCU02A will need to be updated. This update will require a full download.
    • We have the updated application available now.
    • The new version of the application is CPCU02A version 2.18.15.



    If you have questions or require additional information, please contact us and we will be in touch with you shortly.

    Was this article helpful?

    Still can't find
    what you are looking for?

    Our award-winning customer care team is here for you.

    Contact Support

    Powered by