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    Why can't I process a credit card in Sage Timeslips after upgrading from Sage Exchange Desktop v1 to v2?

    Products

    Sage Exchange Desktop (SED), Sage Timeslips


    Description

    After upgrading from SED v1 to v2, a Sage Timeslips user receives an error advising that Sage Exchange is not set up properly when attempting to process a payment. Clicking 'OK' on the error message redirects the user to a window that lists the Merchant ID and Merchant Key, and also has links to download Module SDK and SED v1.


    Cause

    When the Sage Timeslips were originally coded to SED, the SED installer would install a 'Path' Registry Key. The current installers do not include the 'Path' Registry Key. When Sage Timeslips attempts to call SED for payment processing, it is checking to see if SED v1, Module SDK, and the 'Path' Registry Key are present. Since the 'Path' Registry Key is not included in the current installer; Sage Timeslips determines that the SED installation is not complete and returns an error.

    Please Note: This issue can be resolved by manually editing the Registry on any impacted workstation. However, there is a negligible risk to your system, and the fix should, therefore, be implemented by your IT Team or Systems Administrator.


    Resolution

    • From the start menu, open the Registry Editor by typing "Registry Editor" and selecting 'Run as Administrator' to open.

     

    • Navigate to HKEY_CURRENT_USER\Software\Sage Payment Solutions\



    • Select the Sage Payment Solutions Folder and right-click to select 'Make a New Key'. Rename it "Sage Exchange" and press enter to save.



    • In the right pane, right-click in the empty column area under 'Name' and choose 'New' > 'String Value'. Rename the String Value "path" and press ENTER.


     

    • Right-click the newly created path string value and choose 'Modify'.


    • In the Value Data field, enter '1', click 'OK', and close the Registry Editor.


    • Right-click the Sage Exchange Desktop/Paya Connect Desktop, SE2.0/PCD (an icon on your system tray), and choose 'Restart Application'.



    • Restart Timeslips and attempt to process a transaction. You should see the Sage Exchange Desktop/Paya Connect Desktop interface open normally.


    If you have questions or require additional information, please submit a ticket and we will be in touch with you shortly.



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