Looking for something?

You will find your answers here!

    Sorry, we didn't find any relevant articles for you.

    Send us your queries using the form below and we will get back to you with a solution.

    Sage 100 & TLS Compliance

    Please refer to the following article if you are looking for assistance with your Sage 100 product.

    Sage 100 Supported Versions

    If your Sage 100 version is not supported and you need assistance with TLS compliance please contact Paya and/or your channel partner for assistance.

    Sage 100 2017 to current

    These versions of Sage 100 are integrated for Credit Card processing.  The integration leverages Sage Exchange Desktop 2.0 (SED 2.0).  However, your infrastructure may need additional actions to become compliant with TLS 1.1and 1.2 communication protocols.  Please refer to the minimum TLS requirements below.

    A program fix is required to run the settlement report over a compliant TLS protocol

    Sage 100 2013 (ver 5.0) to Sage 100 2016 (ver 5.3) 

    These versions of Sage 100 are integrated for Credit Card processing.  The integration leverages Sage Exchange Desktop 1.0 (SED 1.0).   Paya has set an obsolescence date for SED 1.0 of June 25th, 2018.  Sage Exchange Desktop 2.0 has a legacy service built into the program to support SED 1.0 integrated products.   Customers using these versions of Sage 100 must complete a transition to Sage Exchange Desktop 2.0 (SED 2.0).

    Completely uninstalling SED 1.0 and repairing the Module SDK must be completed before installing SED 2.0. 

    Please refer to this article for information about this process.

    Please refer to this article for the process of installing Sage Exchange Desktop 2.0.

    Your infrastructure may need additional actions to become compliant with TLS 1.1and 1.2 communication protocols. Please refer to the minimum TLS requirements below.

    A program fix is required to run the settlement report over a compliant TLS protocol

    • 2016.5 – program fix AR5011T.zip (Program fix AR5005T.zip is also required to detect installations of SED 2.0.)
    • 2015.5 – program fix AR5010T.zip (Program fix AR5006T.zip is also required to detect installations of SED 2.0.)

    MAS 90/100 ver 4.1 to 4.5

    These versions of MAS 90/100 are integrated for Credit Card processing.  The integration leverages a version of our legacy APIs.  Paya continues to support these legacy APIs, but you may need to take action to become compliant with TLS 1.1and 1.2 communication protocols.  Please refer to the minimum TLS requirements below.  


    TLS 1.1 and 1.2 minimum requirements  for compliance

    Our customers and vendors need to continue working on being TLS 1.2 compliant.  You will need to enable TLS 1.1 and 1.2 security protocols on your servers and workstations. The minimum operating systems that support TLS 1.1 and 1.2 options are Windows Server 2008 R2, and Windows 7. Please ensure that all updates and patches have been applied.  If you are using Linux, please check the Open SSL changelog for the version of your Linux OS that will support TLS 1.2.

    For more information about how to enable TLS 1.1 and 1.2 for Windows operating systems please refer to this link.  Paya has built a program that simplifies the necessary Registry Edits mentioned in the Microsoft article, please click here to download this program.

    Disclaimer:  Usage of these programs should be limited to systems administrators because they could impact system critical services and applications.  Certain services and applications may not be capable of communication over certain TLS protocols; you may need to contact your vendor for TLS 1.1/1.2 compatible version of their solutions.




    If you have questions or require additional information, please contact us and we will be in touch with you shortly.

    Was this article helpful?

    Still can't find
    what you are looking for?

    Our award-winning customer care team is here for you.

    Contact Support

    Powered by